Joost de Valk

Joost de Valk é o fundador e Diretor de Produtos da Yoast. Ele é um profissional de marketing digital, desenvolvedor e uma Fonte Aberta fanático.

Avatar of Joost de Valk

Assim como o WordPress 5.3 vem de fora, Yoast só de suporte do WordPress 5.2 e WordPress 5.3, e não versões anteriores. Isso significa que nós vamos terminar o nosso suporte para WordPress 4.9, que tivéssemos mantido vivo por um pouco mais de tempo do que o habitual para permitir que as pessoas para a transição para o WordPress 5.0 e o clássico editor. Gostaria de explicar por que adotamos esta política e por isso estamos decidindo voltar para ele.

A construção de software para o WordPress pode ser extremamente complexo. Trabalhamos em um mundo onde há sempre um par de versões do WordPress ao redor. Ao lado disso, os plugins podem fazer quase qualquer coisa (o que fazer), o que também significa que eles podem interferir uns com os outros. Cada site tem uma combinação diferente de plugins, levando a dezenas de milhares de combinações diferentes.

Código moderno

Em Yoast temos orgulho em usar as melhores ferramentas disponíveis para criar soluções para nossos usuários. Com o WordPress 5.2, núcleo do WordPress equipe aumentou o mínimo de PHP requisito para WordPress a partir do PHP 5.2 do PHP 5.6. Nós sempre queremos que o nosso software para trabalhar sobre os requisitos mínimos para o WordPress, o que significa que só podemos usar a funcionalidade do PHP 5.2 até então.

Nota: eu sei que esses números de versão e o fato de que eles são tão parecidos pode tornar-se confuso. Nós certamente tinha uma certa confusão em torno do que internamente. Peço desculpas pelo que antecipadamente, mas como você vai entender, eu não posso mudar esses números de versão.

PHP é a linguagem que a maioria das WordPress back-end é construído em. PHP 5.2 foi lançado em 2006, enquanto o PHP 5.6 foi lançado em 2014. Como você pode ver, são 8 anos de diferença, e 8 anos é muito tempo na internet.

Voltando à nossa política de só apoiar o atual e a anterior versão, e, portanto, apenas de suporte do WordPress 5.2 e 5.3, temos que nos permitir desenvolver usando PHP 5.6. Porque podemos usar o PHP 5.6 agora, podemos desenvolver mais rápido e com mais segurança.

O que significa “suporte” significa?

Quando dizemos que não oferecem suporte a uma versão mais antiga do WordPress, isso significa que paramos de teste com ele, e as coisas estão propensos a quebrar. Isso também significa que você não verá Yoast SEO atualizações até que você atualizar o seu WordPress para a versão suportada.

Meu site não funciona com o clássico editor

Por uma pequena porção de sites, eu sei que isso as deixa no limbo, que nós odiamos. Se você tem um personalizados do WordPress solução, construída com versões antigas de plugins como o Advanced Campos Personalizados (ACF), você pode estar “preso”. Mesmo que a ACF tem feito um incrivelmente bom trabalho de migração de Gutenberg, que não podem “salvar” você.

Enquanto nós pensamos que é uma porcaria, nós realmente não temos qualquer opção para você que não para ir para o site do desenvolvedor e explique-lhes que esse não é um estado que você deseja ficar. Você realmente deve se mover para as versões mais recentes do WordPress. Continuaremos a apoiar o Clássico Editor por mais alguns anos, por isso, se eles fazem é trabalhar com o que você é bom.

Eu não vejo qualquer Yoast SEO atualizações

Há um par de razões diferentes por que você não pode ver Yoast SEO atualizações. Como disse acima: se você estiver em uma versão antiga do WordPress, você não vai vê-los. Para atualizar o seu WordPress em primeiro lugar. Se não for esse o caso, reinstale o plugin, basta excluí-lo e instalar a versão mais recente manualmente. Que não exclua qualquer um de seus dados, não se preocupe.

Vá e atualizar seu site!

Então, se você estiver em uma versão antiga do WordPress, vá e atualização. É claro que, antes de fazer qualquer coisa como atualizar plugins ou WordPress, certifique-se sempre de testar e fazer backup de seu site!

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

um × 3 =